Jan 27

Why a T1 Line:

The first and foremost reason a person would choose a T1 for their business internet connection is reliability. T1 lines have a very good uptime, which means they are operational 24/7/365. If you were to have an issue, the service has a high priority to repair. This means that within 4 hrs, the telecom needs to address the issue and figure out what is wrong. They dont guarantee to fix it, but they guarantee to tell you what is wrong within 4 hrs. In most cases they do try their best to fix it as soon as possible. If you have a problem with your DSL line for example, they may not address the issue for a few days. DSL lines have a low priority repair with the telecom companies. So you really dont want to have you business be dependent on a DSL, if you really require service 24/7. You want to know why? Its because DSL lines are so cheap. You get what you pay for when it comes to internet connection service.
Can your business afford to be without internet for a few days?

Physical Layer:

The physical layer is the wiring part of a T1 line. In most cases the telecom will bring a RJ-45 jack and mount it in your server room. When you order the line you tell them where you want it to terminate.

T1 jack

There are 2 kinds of RJ-45 jacks that may be installed. One is a standard RJ-45 jack, which is open when a cable is not connected. And the other automatically loop backs when a cable is not installed. This helps with testing the T1 line during initial installation or troubleshooting if the line is down. If you have a standard jack, you can create your own loop back device for testing the T1 line.
Click to view the T1 loop back device

Equipment: Easiest, Internal DSU/CSU

Internal CSU/DSU cisco router

The easiest way to setup a T1 line for your company is to use a cisco router with an internal CSU/DSU, an example of what it looks like is show on the right. The CSU/DSU is basically like a modem that communicates with the other side in T1 language. Using a cisco router with an internal CSU/DSU just make things a little cleaner in your server room. You can use something like a cisco 1600, 1700, 1800 or 2600 router. They all allow the internal CSU/DSU card to be installed. Click here to see what the Cisco T1 DSU/CSU WAN Interface Card looks like outside of the router. The model number for the card alone is WIC-1DSU-T1-V2. You can find both the router and the card on ebay.com. With this setup you only need to connect an ethernet cable from the RJ-45 jack supplied by the telecom to the Internal DSU/CSU.

Equipment: Newer Style Serial Port, External CSU/DSU

Front View Adtran Back View Adtran

This is an example of some of the equipment that can be used for business T1 line, that doesnt have an internal DSU/CSU card. With this type of setup you will use and external DSU/CSU, like the one shown to the right. When you use an external DSU/CSU you will need to connect 2 items to it. One is the cable(cat5) from the RJ-45, and the other is a V.35 cable that will connect to the cisco router, shown below left. Cisco v.35 Cable This cable has the newer style serial port ends. Its much smaller than the older style, shown in the next section. This setup works well when you dont have any space requirements or limitations. You can find both the router and external CSU/DSU on ebay.com.

Equipment: Older Style Serial Port, External CSU/DSU

Cisco 2500 router Back View Adtran

This is an example of some of the older style equipment that can be used for business T1 line. The first piece of equipment you will need is a cisco 2500 router. Its a few years old, but should still work fine for a single T1 line. Cisco 2500 routers are no longer being made, but can be found in many surplus stores, or on ebay.com.Cisco V.35 Cable, old styleYou still need the external DSU/CSU to make the line work. The picture to the left shows the older style V.35 cable. Notice that the serial port is a little larger when compared to the newer style. You can find both the router and external CSU/DSU on ebay.com.

Router Configuration:

Cisco Admin Cable

Once you have the cable plugged in from the RJ-45 jack(supplied by the telecom) to your cisco router you are ready to configure the router.
You will need to connect to the router using a cable like the one shown to the right. It connects to the serial port of your pc, and the other end connect to console port on the cisco router.
This ia an example config for cisco 1600,1700,1800 and 2600 routers, with an internal DSU/CSU
Once you are logged in you can type the following:
config t
#if you have external DSU/CSU you wont need this part controller t1 0/1
channel-group 1 timeslots 1-24
#end internal DSU/CSU interface serial 0/0/0:1 <===This is you outside interface
no shut
description point to point to internet provider
encap ppp
ip address 192.168.1.1 255.255.255.252
interface Fast 0/0 <===This is you inside interface
ip address 10.20.20.1 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.1.2 <===This is your gateway to your internet provider

13 Responses to “How to Connect a Business T1 Line”

  1. Apple Ipod Says:

    This blog is looking really good, the information is solid. I get discouraged at times until I come across one like this! :)

  2. Anonymous Says:

    Thanks for writing about this. There’s a mass of good tech information on the internet. You’ve got a lot of that info here on your site. I’m impressed – I try to keep a couple blogs reasonably live, but it’s a struggle sometimes. You’ve done a great job with this one. How do you do it?

  3. foreveradog Says:

    Very good well informed ty you for the information. From the guys at Bloggles

  4. Bette Busch Says:

    Good afternoon, just needed you to know I have added your site to my Google bookmarks because of your extraordinary blog layout. But seriously, I think your site has one of the freshest theme I’ve came across. It really helps make reading your blog a lot easier.

  5. DanO Says:

    I have been working on a Cisco 2600 with an internal CSU/DSU. I am a little lost. This blog has helped a little bit. However, would you have some time to contact me with some help? dan@iremedy.net

  6. loans Says:

    I want to thank the blogger very much not only for this post but also for his all previous efforts. I found http://www.hypersurf.com to be greatly interesting. I will be coming back to http://www.hypersurf.com for more information.

  7. T1 Line UK Says:

    A T1 gets you about 1.5 megabits/sec up and down for about ten times the cost of a cable modem.

    The cable modem gets you 10 (or more) megabits/sec down and 1 megabit/sec up minimum though it can boost up to 1.5 megabits up.

    Also the only reason cable modems don’t go 2-3x faster is because time warner throttles the bandwidth to perpetuate the stranglehold the huge telcos have over bandwidth and the internet in general.

    So cables are equal/slightly-less up rate as T1 and vastly superior downrate as T1. But they cost 1/10 as much.

    So what is the point of a T1 line?

    Just the reliability and consistency of 1.5 megabits/sec 24/7?

  8. admin Says:

    Yes you are paying for reliability. The speed is not fast nowadays, but 5-10 yrs ago, that was enough. Still most small to medium businesses can utilize a T1 and also have high reliability.

  9. Bruce Says:

    I have a 1600 with an internal T1dsu/csu card and it looks like the “serial0″ according to show ip int br

    I also have a 1705 with an internal T1dsu/csu card and it looks like the “serial0″ according to show ip int br

    How can I make these 2 work in my lab… I connected an x-over and configured the serial interfaces with a sample of

    Interface serial0
    service-module t1 clock source internal
    service-module t1 timeslots 1-24 speed 64
    service-module t1 framing esf
    service-module t1 linecode b8zs
    ip address 10.1.1.1 255.255.255.0
    encapsulation ppp
    no shut

    and
    Interface serial0
    service-module t1 clock source internal
    service-module t1 timeslots 1-24 speed 64
    service-module t1 framing esf
    service-module t1 linecode b8zs
    ip address 10.1.1.2 255.255.255.0
    encapsulation ppp
    no shut

    and with show ip int br both show this:

    Router#show ip int br
    Interface IP-Address OK? Method Status Prot
    ocol
    FastEthernet0 unassigned YES unset administratively down down

    Serial0 10.1.1.1 YES manual down down

    As you can tell, this is my level of T1 cards…

    Help! Again a lab environment…

    Thx

  10. ray Says:

    we’re moving our 911 system (2 servers – primary & secondary) from one location to a temp spot for 3 months. we have a t1 line and in order to prevent any downtime of the 911 system, i’m wondering if the t1 can be extended from the d-mark out to the new location and be live at the same time as the existing feed is?

    In other words is it possible to run a t1 off the d-mark to 2 jacks and have them both live at the same time?

  11. admin Says:

    No you cant “split” the T1 line.
    But you can extend or split the ethernet. I would come from a switch in one building and extend to another building.
    Of course ethernet can only be run 100M, so you may have to make it a fiber connection.

    Or you can extend “hot cut” the T1 to the new location, and only have it be down for a few moments.

  12. Martin McGill Says:

    Great refresher info on the CSU/DSU, thanks! I am trying to remember what the connectivitydevice was called, prior to the CSU/DSU. Was it a Channel Bank?

  13. SolveForce Says:

    Nice work admin! One of the few sites I have seen that not only explains what a T1 is, but also gives pictures and instructions for configuration. Yours Truly, Team SolveForce

Leave a Reply

Get Adobe Flash playerPlugin by wpburn.com wordpress themes