Sep 06

Companies are finding that their current bandwidth requirements are increasing. This means that your current T1 or dual T1 connections to the Internet are getting overloaded. Luckily there is a new technology that can help. Its called Metro Ethernet.
Metro Ethernet is a fiber connection that is dropped at your business. It can be a fiber connection or a regular cat 5 Ethernet connection depending on how its ordered. The great part is that it can be upgraded to higher speeds without having to get a new connection. The old T1 technology usually required some equipment change.

In addition to providing Metro Ethernet Hypersurf Internet Services, Inc can provide Firewall and VOIP services for your company.

http://www.hypersurf.com/metro-ethernet.html

Feb 27

Sometimes we are called by clients that report slow speeds on their Internet service. When we check the Internet service and find no errors most commonly the problem is usually an Ethernet problem cause by an Ethernet speed mismatch or an Ethernet duplex mismatch.

Most Ethernet switch ports are usually set to auto negotiation in the switch port configuration. Auto negotiation attempts to choose a speed and duplex for the Ethernet link between the two ports. For auto negotiation to work it must be set on both switch ports that are attempting to communicate with each other. It can not be set on just one side. Sometimes even thought you have auto negotiation set on both sides of a link it can still make an error in picking the correct speed or duplex of the Ethernet link between the two ports. When auto negotiation fails the links uses another process called parallel detection to choose the speed and duplex of the link. Parallel detection will usually cause the speed or duplex to be set different on both ends of the Ethernet link. The results will then be an Ethernet link that has errors and creates a slow connection.

The best solution is to hard code the speed and duplex of the Ethernet links that are critical in your network. Critical links would be the Ethernet links between you T1 router, T3 router, Ethernet Internet connection, Firewall and switches. Setting the speed and duplex on the critical links will ensure you will get the best Ethernet performance along your Ethernet path.

Check out www.hypersurf.com/ethernet.html

Feb 13

If I have any trouble with my firewall I would like to be able to access the console of the firewall without going in to the office. I have a Cisco 2600 router connected to the Internet with T1 service. I noticed the Cisco T1 router had an extra aux serial port that I could use. I started by configuring the aux port in the Cisco router. In the Aux port I put the following configuration.

router#config t
router(config)#line aux 0
router(config-line)#modem InOut
router(config-line)#transport input all
router(config-line)#speed 9600
router(config-line)#stopbits 1
router(config-line)#exec-timeout 120 0
router(config-line)#exit

Next I configured a loopback interface on the router.
router#config t
router(config)#int loopback 0
router(config-if)#ip address 192.168.0.1 255.255.255.0
router(config-if)#no shut
router(config-if)#exit

Now I must determine what is the line number of the serial port on my router.

router#show line
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise
Overruns Int
0 CTY - - - - - 0 0 0/0
-
65 AUX 9600/9600 - inout - - - 8 0 2177/0
-
* 66 VTY - - - - - 24 0 0/0
-
67 VTY - - - - - 3 0 0/0
-
68 VTY - - - - - 1 0 0/0
-
69 VTY - - - - - 0 0 0/0
-
70 VTY - - - - - 0 0 0/0

On my router my aux port is using line 65.
Now after I telnet in to my router I would then telnet to my loopback address. I would telnet to port (2000 +65). Cisco always uses 2000 plus the port number from show line to determine the port number for accessing the port.
So on the router
router#telnet 192.168.0.1 2065
This would connect me to the serial port of my firewall.
To disconnect from the firewall hold the CTRL+SHIFT+6 keys together then press x. Now you will be back on the router command line. Now type clear line 65 to disconnect the aux line.

To physically connect the firewall to the Cisco router aux port you would use a straight through serial cable.

Don’t forget this kind of configuration could open a huge security risk on your network so always configure your Cisco router to have telnet access from only trusted ip addresses.

router#config t
router(config)#line vty 0 4
router(config-if)#access-class 129 in
router(config-if)#exec-timeout 120 0
router(config-if)#exit
router(config)# access-list 129 permit ip host 192.168.1.1 any (where 192.168.1.1 is the ip of your trusted host.)
router(config)# access-list 129 deny  ip any any log
router(config)# exit

Now your router and aux port will be only accessible from your trusted ip address.
I now can access the serial port of my firewall remotely if I have a problem.

Jan 27

Why a T1 Line:

The first and foremost reason a person would choose a T1 for their business internet connection is reliability. T1 lines have a very good uptime, which means they are operational 24/7/365. If you were to have an issue, the service has a high priority to repair. This means that within 4 hrs, the telecom needs to address the issue and figure out what is wrong. They dont guarantee to fix it, but they guarantee to tell you what is wrong within 4 hrs. In most cases they do try their best to fix it as soon as possible. If you have a problem with your DSL line for example, they may not address the issue for a few days. DSL lines have a low priority repair with the telecom companies. So you really dont want to have you business be dependent on a DSL, if you really require service 24/7. You want to know why? Its because DSL lines are so cheap. You get what you pay for when it comes to internet connection service.
Can your business afford to be without internet for a few days?

Physical Layer:

The physical layer is the wiring part of a T1 line. In most cases the telecom will bring a RJ-45 jack and mount it in your server room. When you order the line you tell them where you want it to terminate.

T1 jack

There are 2 kinds of RJ-45 jacks that may be installed. One is a standard RJ-45 jack, which is open when a cable is not connected. And the other automatically loop backs when a cable is not installed. This helps with testing the T1 line during initial installation or troubleshooting if the line is down. If you have a standard jack, you can create your own loop back device for testing the T1 line.
Click to view the T1 loop back device

Equipment: Easiest, Internal DSU/CSU

Internal CSU/DSU cisco router

The easiest way to setup a T1 line for your company is to use a cisco router with an internal CSU/DSU, an example of what it looks like is show on the right. The CSU/DSU is basically like a modem that communicates with the other side in T1 language. Using a cisco router with an internal CSU/DSU just make things a little cleaner in your server room. You can use something like a cisco 1600, 1700, 1800 or 2600 router. They all allow the internal CSU/DSU card to be installed. Click here to see what the Cisco T1 DSU/CSU WAN Interface Card looks like outside of the router. The model number for the card alone is WIC-1DSU-T1-V2. You can find both the router and the card on ebay.com. With this setup you only need to connect an ethernet cable from the RJ-45 jack supplied by the telecom to the Internal DSU/CSU.

Equipment: Newer Style Serial Port, External CSU/DSU

Front View Adtran Back View Adtran

This is an example of some of the equipment that can be used for business T1 line, that doesnt have an internal DSU/CSU card. With this type of setup you will use and external DSU/CSU, like the one shown to the right. When you use an external DSU/CSU you will need to connect 2 items to it. One is the cable(cat5) from the RJ-45, and the other is a V.35 cable that will connect to the cisco router, shown below left. Cisco v.35 Cable This cable has the newer style serial port ends. Its much smaller than the older style, shown in the next section. This setup works well when you dont have any space requirements or limitations. You can find both the router and external CSU/DSU on ebay.com.

Equipment: Older Style Serial Port, External CSU/DSU

Cisco 2500 router Back View Adtran

This is an example of some of the older style equipment that can be used for business T1 line. The first piece of equipment you will need is a cisco 2500 router. Its a few years old, but should still work fine for a single T1 line. Cisco 2500 routers are no longer being made, but can be found in many surplus stores, or on ebay.com.Cisco V.35 Cable, old styleYou still need the external DSU/CSU to make the line work. The picture to the left shows the older style V.35 cable. Notice that the serial port is a little larger when compared to the newer style. You can find both the router and external CSU/DSU on ebay.com.

Router Configuration:

Cisco Admin Cable

Once you have the cable plugged in from the RJ-45 jack(supplied by the telecom) to your cisco router you are ready to configure the router.
You will need to connect to the router using a cable like the one shown to the right. It connects to the serial port of your pc, and the other end connect to console port on the cisco router.
This ia an example config for cisco 1600,1700,1800 and 2600 routers, with an internal DSU/CSU
Once you are logged in you can type the following:
config t
#if you have external DSU/CSU you wont need this part controller t1 0/1
channel-group 1 timeslots 1-24
#end internal DSU/CSU interface serial 0/0/0:1 <===This is you outside interface
no shut
description point to point to internet provider
encap ppp
ip address 192.168.1.1 255.255.255.252
interface Fast 0/0 <===This is you inside interface
ip address 10.20.20.1 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.1.2 <===This is your gateway to your internet provider

Get Adobe Flash playerPlugin by wpburn.com wordpress themes